Mobile appears to remove reply focus on replies after device locks


#1

Hello,

I’m on Android using Chrome to access these forums; on a couple of instances, I have hit the reply button on a post and started typing a reply, only to lock my device and come back to finishing my response later. When I eventually do post the reply, the reply connector usually attached to the post being replied to has disappeared from the post. Is this something that just isn’t showing up on mobile for whatever reason, or is the link between original post and reply just disappearing?

Here is an example:

I started this post as a reply to Post #52, but it doesn’t seem to have that link.


#2

I think it’s a wider issue with Discourse because I’m on desktop and also have definitely hit the right reply button a few times, replied, and the thing doesn’t include the “replied to” tag correctly.

I’ve also seen quite a lot of other post that are clearly short replies to something a few posts back but isn’t tagged as such.


#3

Hi, thanks for the feedback! This sounds like an bug that may have be addressed to developers. We can certainly take a look into it but may not be something we can reproduce or innately fix on our end. If it appears to be that way, we’ll definitely send this feedback to forum devs!


#4

Hi! Do you mind linking me a couple examples of this aside from the OP’s example? It’ll help in bringing it up to forum developers with more of them on hand!


#5

Cool! I always imagined this was a forum tech issue, just wasn’t sure where to submit it other than here. I’ll see if I can find some of my other instances of this issue, as well.

(I also inadvertently locked my phone in the middle of typing this response. Repeatability, maybe?)


#6

Oh my! Haha, no definitely bring up these issues in here. It is a form of “site feedback” and it’s something we want to address and try to solve if it is an issue for the community. So good looking out and thanks for reporting it!


#7

Ok, so in trying to find a good example of this from my own posting (so I know it’s not just “hit reply at bottom”) I think I’ve worked out why I’ve been slightly confused but this isn’t a bug. The few times I’ve seen what looked to be an orphaned reply it way never my reply so could just be the user clicking the wrong reply button (which you’d expect to happen a bit).

In my notifications [replied] jerbypuff How Do Y’all Feel About Anchovies 3h.

No indication of the reply to… because it immediately follows the post it was a threaded reply to.
Except if someone replies to the topic in general or first post, they also get flagged this way. So some replies don’t get flagged as direct replies because they’re directly below the post replied to but not all posts below one are replying to the one above.

Having quickly scanned over some of my previous posts, this seems to be the consistent behaviour of Discourse so my post above was wrong. I don’t think I’ve encountered a bug, I just failed to understand how the reply to flagging worked.


#8

About to test this theory by replying to you. All of my issues were also instances where the reply I wrote came directly after the post being replied to. Maybe this bug is a feature?


#9

Yep this bug is a feature (Just got your notification of this reply - I’m also replying to your last post and expect it will give you a notification but won’t display it on the main thread as being a direct reply).


#10

Hm, that’s very strange though as you would consider this being a reply directly to a person if you’re hitting the reply on the button on the bottom of their post. If it isn’t a bug then it’s definitely a feature to be considered if it can be implemented.


#11

Cool, I think it would make the interface clearer if it flagged all direct replies as such (but can see why the designers might have decided it is cleaner to omit them). It may be something hidden in the Discourse settings that can toggle between several levels of verbosity (I’ve never had to configure an instance so I’m not sure how configurable it is around stuff like this).


#12

A little digging round on the Discourse site reveals that this is a conscious decision by the developers in their design.

They do offer some site settings to mess around with this aesthetic. Still, I’ll bring this up in future discussion!


#13

Yeah, the Discourse people do some odd things here and there.


#14

Good to know! Cleanliness of UI vs. Consistency is a tough call (although I prefer consistency, personally).


#15

Wow, so this “feature” was driving me up the wall until I did a little searching and found this explanation. I thought the forum was not treating my replies to other user’s posts as replies and was just making them standalone posts. I sort of understand why its like this, but the inconsistency on the reply icon appearing or not made things a little confusing. I thought it was a bug…


#16

Oh yes, as you can see by the flow of discussion it was a surprise to us as well! This is a fairly new software system for myself and most others, so we were (and still are!) getting used to everything. Glad this post helped you to understand what was going on.