Odd Glitch in Waypoint's Podcast Feed


#1

Yo, for the past few months the Waypoint radio and Wapoint UK podcast feeds would randomly change names and just start downloading episodes of other very random podcasts.

This just happened a few minutes ago to me again, with the podcast changing its show art, and telling me that there are 9 new episodes of Waypoint Radio.

This is what Waypoint Radio looks like right now in my feed.

I’m running the iOS 11 public beta, but this still occurred when I was running iOS 10. Please fix this, it’s really annoying!


#2

That’s pretty funny, because in Pocket Casts there is the exact opposite problem: it still refers to it as “VICE Gaming’s New Podcast.”


#3

What app are you using? I use podcast addict on my Android Samsung phone and don’t see any of these issues. Plus, the iTunes lists of episodes has been doing anything weird.

I have had the downloaded episodes sometimes having ads at the start (the same type of UK ads I see when I visit the Waypoint site), thought that may be the Podcast Addict app (although it hasn’t happened with any other downloads). Regardless, I haven’t had any of the downloads being different podcasts.
Could you check the RSS feed your app is downloading from (is it sent to a general vice RSS feed)?


#4

I use the stock iOS podcasts app.

Look at what the feed is doing to me now:

:joy:


#5

That does seem annoying but I’m not getting any of that. Have you tried unsubscribing and re-subscribing to the podcast?


#6

tried that with iOS 10. will try again now that i’m on iOS 11. the problem though is that, this occurs every three or four months, so i won’t be able to tell if it worked immediately


#7

what feed are you subscribing from? My phone app subscribes to the UK iTunes feed and I haven’t has this issue with it.


#8

South African iTunes


#9

I googled it from the UK so I may be wrong, however I believe this is the South African iTunes link and it just has the Waypoint Radio episodes in it. Does your app say this is the same as what you are subscribing to?

I’m obviously not a Waypoint staff member, but this is the limit of how much I can see to help since I don’t have this issue. (Also, hello to South Africa).


#10

The feed if you just look at available episodes is fine. It just magically decides to download episodes from other podcasts, so not sure what the problem is either


#11

Fwiw I use player.fm in the UK and I’ve had it download random episodes of unrelated casts, put those hotel ads at the beginning and end of eps a couple weeks ago (I was getting the same ads if I listened from the website - honestly I just assumed they were ads Vice/Waypoint were being paid for), sometimes download two copies of an episode, and sometimes tell me the run time is 10 minutes longer than it actually is. Honestly, WP’s podcast feed just seems borked, to me.


#12

I had that with a Football podcast and one other as well. In the end I unsubscribed, deleted any podcasts of that feed I had, then deleted them from the temp bin (or whatever it is, you tell it to delete and then it sticks it somewhere for 30 days for some reason, before completely deleting). Then re-started and re-subscribed. Fixed it in the end (think I did that process three times). I have an iTouch but would assume it’s the same fix, assuming it’s the same issue.