PSA Phantom Dust is free!


#1

#2

Never played but have always wanted to, sooooo… cool!


#3

Phantom Dust being free is tempting me to restart my battle to get my desktop update to Windows 10.


#4

I’ve done the upgrade like 10 times and have never had an issue, but I know plenty who have. Some hardware just doesn’t work well I guess. Good luck!

Edit - tens times to my multitude of machines and friends and family’s, not all just over and over again to mine


#5

I’m like 75% sure I’ve figured out what the issue is, but it means I’m going to have to take the computer apart and most days I just don’t feel like it. But a game that I’ve wanted to try for years being made available for free maaaay be enough to motivate me.


#6

I downloaded it on PC but my Xbox One controller isn’t working with it so lmao


#7

I had a problem with my 360 controller, but then I remembered that I had disabled the HID Compliant Game Controller driver to play Binary Domain. Once I re-enabled that driver and restarted the game, it worked just fine.


#8

You’re doing better than me. I’m one of the many Activation of application failed with error: The remote procedure call failed. So immediate crash on load (if you dig into Window’s error logs as an admin). Love the given location of the error dump is apparently flushed on crash so I can’t even see what it does before crashing without attaching a debugger (and it’s not just a folder with an executable and data I can browse myself, because UWP).

Really glad I used MS’s comically slow CDN service (even EA and Ubi have figured out how to serve files to Europe at fibre speeds) to download a totally useless app for now. I play a lot of PC games, sometimes they don’t work right but generally I’m not dealing with apps simply not working and yet this is totally broken for plenty of users and Forza Horizon 3 the second you go offline also just crashes on startup rather than giving any on-screen display of why it doesn’t work (the answer for FH3 is DRM that is not listed on the Win10 Store - the game has no persistent offline mode outside of the XB1 version). It’s like UWP is still not fit for purpose as a replacement for Win32 as a platform for developing games on.

Oh, and UWP continues to be a general pleasure to work with:

Why would I try again in a bit? Has that advice ever worked? Isn’t this a year-long core defect in the moving subsystem in UWP apps that is never going to be fixed?


#9

That is very unfortunate to hear my friend! I’ve just been lucky. I have heard from plenty of people that the Windows store has issues. I think I encountered one once with GoW 4, but that was solved by clearing the store cache and restarting the store app.

It is very disheartening because most Steam games just work, at least in my experience, and so for the official Microsoft store to be so busted is very confusing. I played a few hours of Phantom Dust last night, and I am not sure how I feel about it. I think it has alot of cool ideas, and the destructible environment s are cool, but the “missions” are literally just arenas with different bad guys thrown in. I hope this free remaster is a litmus test for a potential sequel/reimagining because an open world or better hardware for developers could make this a really cool game.


#10

If you can’t launch Phantom Dust on Win 10: Go to your speakers and set your format to 24bit 48000 hz


#11

Wow, thanks. Fixed it, hadn’t seen anyone figuring that out yesterday when everyone discovered the issue.

So they shipped a game that can’t RPC (presumably) to attach an audio driver (the standard Windows one now we’re in the world of everything being software) if you’re using a format they’re not expecting (despite this being something you absolutely have to expect a range of values for). How do you just crash with a silent RPC error rather than giving feedback to the user saying what failed?

o_O